Node-exporter is not running on 3 nodes of the cluster


I run node-exporter as a daemonset inside AWS EKS and found today that it's present on 10 nodes, however my cluster has 13 nodes.

How do I make sure it also runs on 3 missed nodes?

-- DmitrySemenov

1 Answer


Tolerate the daemonset using:

  - effect: NoSchedule         
    operator: Exists

Per Docs DeamonSets already have a few tolerations by default. The no-key one I posted is making sure you are covering all possible reasons of NoSchedule:

An empty key with operator Exists matches all keys, values and effects which means this will tolerate everything.

This is a commonly used setting for monitoring daemons and log collectors.

-- Max Lobur
Source: StackOverflow