I am currently working on deploying Apache Airflow 1.10.0 to a Kubernetes cluster. I am running into some dependency issues with Flask.
If I use the current version of flask-login (0.4.1), I receive this error:
apache-airflow 1.10.0 has requirement flask-login==0.2.11, but you'll have flask-login 0.4.1 which is incompatible.
With this error, the UI won’t render, and instead, I see a text bomb followed by many flask-appbuilder/flask-login warnings.
If I use the Airflow’s requirement of flask-login (0.2.11), I receive this error:
flask-appbuilder 1.12.0 has requirement Flask-Login<0.5,>=0.3, but you'll have flask-login 0.2.11 which is incompatible.
With this error, the UI renders with Airflow 1.9 features and CeleryExecutor won’t work.
This was fixed with an Airflow update: https://github.com/apache/airflow/blob/master/UPDATING.md